Mozilla Firefox 3.5.6 Patches Security Vulnerabilities

Mozilla, an open-source browser software developer has shipped Firefox 3.5.6 with patches on some security vulnerabilities.
The said flaws could lead remote code execution attacks, Denial of Services, URL Spoofing, etc. End users of this browser on all platforms including Mac, Windows, and Linux- are affected.

These are the details of Mozilla Firefox 3.5.6 Security Fixes:

Mozilla Foundation Security Advisory 2009-65 (Critical) – Crashes with evidence of memory corruption (rv:1.9.1.6/ 1.9.0.16)
Mozilla Foundation Security Advisory 2009-66 (Critical) – Memory safety fixes in liboggplay media library
Mozilla Foundation Security Advisory 2009-67 (Critical) – Integer overflow, crash in libtheora video library
Mozilla Foundation Security Advisory 2009-68 (High) – NTLM reflection vulnerability
Mozilla Foundation Security Advisory 2009-69 (Moderate) – Location bar spoofing vulnerabilities
Mozilla Foundation Security Advisory 2009-70 (Moderate) – Privilege escalation via chrome window.opener
Mozilla Foundation Security Advisory 2009-71 (Low) – GeckoActiveXObject exception messages can be used to enumerate installed COM objects

Users are urgently encouraged to update their browser via automatic-update built into Firefox.

To get more Firefox updates, you can subscribe either by E-mail or by RSS Feeds.