Ultrasn0w to Unlock Baseband 5.15.04 on iPhone 3G and 3GS

Confirmed! Yesterday, we have been tipped off that the Ultrasn0w unlock for baseband 5.14.02 on iPhone 3G and 3GS running iOS 4.1 will be available this Sunday.

And one thing pointed out is whether the updated version of Ultrasn0w will also unlock baseband 5.15.04 on iOS 4.2.1 or not. Well, there’s a change of story and this time – it’s more precise. @MuscleNerd of the Dev Team just confirmed that the updated Ultrasn0w set to be released this Sunday is also capable of unlocking baseband 5.15.04 on iPhone 3G and 3GS running iOS 4.2.1.

@ssstephD it covers 05.15.04 too — but yeah, really need to stay vigilant about not updating :(

That’s ultimately a good news for those iPhone 3G/3GS users who accidentally upgraded there device to iOS 4.2.1 as well as to the latest baseband.

iPhone 4 users can still use the upcoming updated Ultrasn0w to unlock baseband 1.59.00, however those who has baseband 2.10.04 still need to wait longer as the Dev Team still working on it.

Update 1: iOS 4.2.1 Unlock for iPhone 3G and 3GS Released!
Update 2: Unlock Baseband 5.14.02 and 5.15.04 on iPhone 3G or 3GS

To receive latest technology updates, you can subscribe either by E-mail or by RSS Feeds. Follow me also on Twitter.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>